EQUIPMENT OPERATION MANUAL

Cartesian 200, 300, 400 and 500 Series
& SCARA S440 Series

PC Operation
Thank you for purchasing a Loctite® Robot.
*Read this manual thoroughly in order to properly use this robot.
*After having read this manual, keep it in a handy place so that you or the
operator can refer to it whenever necessary.
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PREFACE
The “LR C-Points” is an enhanced version of the existing PC software, LR C-Points Limited
Edition. This software will help you to operate the SCARA robot and the Cartesian series
robots. Its features are affordable price, cost efficiency, diverse applications, high speed,
rigidity and precision. Furthermore, it can accommodate a wide variety of requirements.
By using the “LR C-Points”, you can save, read, add, insert, delete, or edit C&T data, and can
also perform JOG teaching operations via PC. You can also register programs via PC,
without connecting the teaching pendant.
This operation manual explains how to use the “LR C-Points” software.
Operating methods such as clicking the mouse and use of dialog boxes for “LR C-Points” are
the same as those of Microsoft Windows® 2000 applications.
For details of Windows® 2000 operating methods, refer to the instruction manual supplied with
Windows® 2000.

Warning

When transmitting C & T data between the PC and the robot,
be sure to save the data in a file for backup.

Windows, Excel, Word are registered trademarks of Microsoft Corporation.
Lotus 1-2-3 is a registered trademarks of Lotus Development Corporation.
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HARDWARE REQUIREMENTS
To operate the “LR C-Points”, “LR C-Points Limited Edition (included in the Cartesian
Series Operation Manual CD-ROM)” software on your PC, the following is required.

Personal Computer
Should be configured for use with Windows® 2000/XP.
Memory Capacity
A minimum of 32 MB of memory is required to operate the “LR C-Points” or “LR
C-Points Limited Edition” normally.
Operating System
Microsoft Windows®2000/XP
Hard Disk Capacity
A minimum of 20 MB of hard disk space is required after installing Windows®
2000/XP.
COM Port
One vacant COM port is required to connect the robot to the PC.

The required memory capacity or hard disk space may vary depending on the system
environment.
Insufficient hard disk space may cause insufficient memory or trouble while operating.
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CONNECTION
To transmit teaching data to the robot from the PC, connect the two with an RS-232C
straight cable (as illustrated below.)
For details of the communication cable wiring, refer to page 46.
[PC]

RS-232C

Refer to the instruction
manual supplied with your
PC.

Straight

[Robot
] 9-pin

Connect one end of the RS-232C cable to the RS-232C connector on the robot (on the
control box for the SCARA series, on the robot body for the Cartesian series) and the
other end to the COM port (serial connector/RS-232C) on the PC.
When operating the robot via the PC, be sure to disconnect the teaching pendant from
the control box and connect a grip switch to the teaching pendant connector instead.
When operating the robot via the PC,
SCARA Series: Be sure to disconnect the teaching pendant and connect a grip switch to
the teaching pendant connector instead.
Cartesian Series: Be sure to disconnect the teaching pendant. (If you use a teaching
pendant with an enable switch and an emergency stop switch, connect a grip switch to
the teaching pendant connector.)
Be sure to turn off the power to the PC and the robot
before inserting or removing the cable.
<Body Front>

Cartesian Series

COM1

Teaching Pendant Connector (TPU)
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SCARA Series

COM1

<Control Box (rear)>

Teaching Pendant
Connector (TPU)

<Control Box (front)>

When operating the robot via the PC, be sure to disconnect the teaching pendant
from the control box and connect a grip switch to the teaching pendant connector
instead. (If you use a teaching pendant without an enable switch and an emergency
stop switch in the Cartesian series, it is not necessary to connect a grip switch.)
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Emergency Stop

Enable Switch

<Grip Switch>

If you use a teaching pendant with an enable switch but without an emergency stop
switch with the Cartesian series, use a grip switch with an emergency stop switch
only. If you use a teaching pendant with an emergency stop switch but without an
enable stop switch, use a grip switch with an enable switch only.
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INSTALLATION AND UNINSTALLATION
Install the “LR C-Points” software onto your PC before operation.
INSTALLATION
1. Start Windows® and check that it is functioning correctly. Before installation, close all
applications.
2. Insert the “LR C-Points” CD-ROM into the CD-ROM drive.
3. The installer automatically starts up. Follow the onscreen instructions.
If the Installer Doesn’t Start up Automatically,
1. Select [Settings] from the Windows® [Start] menu and click [Control Panel.]
Double-click [Add or Remove Programs.]
2. Click the [Add New Programs] button and select [CD or Floppy.]
3. Click the [Next] button in the new dialog box and check that the CD-ROM drive
“\SETUP.EXE” is set in the command line of the setup program.
4. Follow the onscreen instructions.

Enter the serial number affixed to the back of the CD-ROM case in one-byte characters.
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UN-INSTALLATION

®

1. Select [Settings] from the Windows [Start] menu and click [Control Panel.] Double-

click [Add or Remove Programs.]
2. Click [Change or Remove Programs.] Select “LR C-Points” from the currently

installed program list and click the [Change/Remove] button.
3. Un-installation of the LR C-Points will be started.
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START AND EXIT
Start
Use one of the following two methods to start up the “LR CPoints” software.
1. Select [Program] from the [Start] menu of Windows® and
click [LR C-Points.]
2. Click the shortcut icon on the desktop.

LR C-Points for Dispensing.lnk

The LR C-Points can be started even when the PC and the robot are not connected or
when the power to the robot is OFF.
However, a “communication error” will be returned and information stored in the robot
will not be read out to the PC. Set the “Model Name” and “Axis Info” (number of Axis)
of your robot and click [OK.]
In this case, you cannot operate the robot via the PC.
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Exit
Use one of the following two methods to exit the “LR C-Points” software.

•

Click [Exit] on the [File] pull-down
menu.
or

•

Click the
(Exit) button on the
upper right corner of the screen.

If unsaved C&T data is open, the Exit
confirmation dialog box will appear.
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SCREEN
C&T Data File Name
Pull-Down Menu

Menu Bar
Program Number and Name

Point Data Item
Status Bar

Model Name and Axis Info.

C&T Data File Name: Name of the currently open C&T data file
“LR C-Points” menu: Click an item to display a pull-down
Menu Bar:
menu.
Tool Bar: Shortcut icon alignment
Pull-Down Menu: Appears when clicking an item on the menu bar.
Program Number and
Number and name of the currently open (selected) program
Name:
Point Data Item: Items can be set to point data
Status Item: Describes the PC status.
Model Name and Axis Info: Model name and Axis of the robot connected to the PC
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Icon Functions
Icon

Function
Open a new (C&T data) file.

Similar Menu Item
File – New

Open an existing file.

File – Open

Overwrite the currently open file.

File – Save As

Print

File – Print

Cut the currently selected point.
Copy the selected cell to the clipboard.

Edit – Cut
Edit – Copy

Paste the clipboard contents to the cell.

Edit – Paste

Redisplay
Display the “LR C-Points” version
information.
Add a (PTP) point to the end of the
program.
Insert a (PTP) point.

View – Refresh

Delete a point.

Edit – Delete Point

Help – Version Information
Edit – Add Point
Edit – Insert Point

Add a PTP point to the end of the program.
Add a CP start point to the end of the
program.
Add a CP passing point to the end of the
program.
Add a CP stop point to the end of the
program.
Add a CP arc point to the end of the
program.
Add a CP end point to the end of the
program.
Add a PTP evasion point to the end of the
program.
Turn the motor power to the robot ON.
(SCARA Series)
Execute mechanical initialization of the
robot. (Cartesian Series)
Operate the robot in JOG mode.
The robot executes a “GO MOVE”
operation.
(To change settings of a point)
The robot executes a “GO plus MOVE”
operation.
(To confirm settings of a point)
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Robot – Motor Power ON
Robot – Mechanical
Initialization
Robot – JOG
Robot – Go Move
Robot – Go Plus Move
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The robot executes a point playback.

Robot – Point Playback

The robot executes a test run.

Robot – Test Running

Add a program.

Program – Add Program

Delete the currently selected program.
Program – Delete Program
Click [Toolbar] on the [View] pull-down menu to display or hide the icons.
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OPERATION PROCESS
The following chart shows the process for creating C&T data with this application and
sending the data to the robot.
Open
C&T data

Open
C&T data

Open
C&T data

New

Open File

Receive
from the robot

*1

Change
C&T data
*2
*2
Save File
(Backup)

Send
C&T data
to the robot

*1: In this case, “file” indicates the extension “.cps” file stored in the PC.
*2: Before sending C&T data to the robot, be sure to back up the data to a file in case of
communication error.
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C&T DATA
This section explains the C&T data handled with this application. “C&T” stands for
Customizing and Teaching data.
In this application, the teaching data is always handled (e.g. File Open, Save File, Send
to Robot, Receive from Robot) in combination with the customizing data. The unit of
data is called “C&T data.” You cannot save, receive and send only the teaching data or
only the program.
Only one unit of C&T data can be saved in the robot at one time. Accordingly, if
you send the C&T data from the PC to the robot, the data stored in the robot will
be overwritten (deleted.)

C&T data
Customizing
data

Teaching
data

The C&T data contains all the setting values and data stored in the robot except the
settings below. (You cannot change the settings below by PC.)
When changing any of the settings except the following or creating and editing any
program or point job data, open the C&T data first.
Teaching Environments Setting
Settings displayed by pressing the T.ENV key on the teaching pendant
Administration Settings
• Start Channel
• Program Number Change Invalid
• COM Setting
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NEW
Click [New] on the [File] pull-down menu.
The new C&T data file will open.
In this case, no contents are displayed on
the screen since no program is open.
A new C&T data file opens when the
application is started up.

You cannot open multiple units of
C&T data at one time. If a C&T data
file is already open, close it before opening a new C&T data file.
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OPEN/SAVE
This section explains how to open or save to a C&T data file in the PC. To change or
open the C&T data in the robot, refer to the “Communication” section on page 16.
Before sending the C&T data to the robot, back up the data to a file in case of error.

Save to (.cps) File
Click [Save] or [Save As] on the [File]
pull-down menu.
When saving the data in a file, if any
setting value included in the C&T
data exceeds the entry range, the
upper/lower value of the range is
saved instead. However, if a
sequencer program number and a
point data or additional function data
number assigned to the point data
exceeds the entry range, “0”
(meaning “not registered”) is saved.
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Open (an Extension “.cps”) File
1. Click [Open] on the [File] pull-down menu.
You cannot open multiple units of C&T data at one time. If a C&T data file is already open, close
it before opening a new C&T data file.
2.

Select a file to be opened.

Read JCS File (an Extension “.cps” File)
You can convert a CAD drawing (DXF file) into a JCS file using the Dxf2Robot software
and read it.
1. Click [Import] on the [File] pull-down menu.
2. Select a file to be opened.
The JCS file length is not fixed. Select the unit of length (mm/inch) here.
3. Select a number for the data included in the JCS file (a program number from the
C&T data) and click [OK.]
If the C&T Data Is Not Open
The screen displays new C&T data which contains only one (selected) program.
If the C&T Data Is Already Open
The screen displays that a new (selected) program has been added to the currently
open C&T data.
Once opened, a JCS file cannot be saved again unless converted into a (.cps) C&T
data file.
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COMMUNICATION
Before using created C&T data, it has to be transmitted to the robot. To open the C&T
data file currently being used in the robot, it has to be transmitted to the PC.
When using this application, all data is handled in the unit (C&T data) described in the
previous section. You cannot send or receive a specific program or specific point data
even when transmitting data between the PC and the robot.

Be sure to send, receive, or read information between the robot and the PC
under the following conditions.
•

Teaching base condition
(The point setting screen or new position entry screen is displayed in the teaching
mode.)
• Wait for start condition
(The robot is waiting for start at the work home position either in the run or
external run mode.)
• Customizing mode base condition
(The customizing mode menu screen is displayed.)
• Administration mode base condition
(The administration mode menu is displayed.)

How to Receive Data
Click [Receive C&T Data] [Robot] on the [Robot] pull-down menu.
The robot will start to send the C&T data to the PC. When the transmission is complete,
the received C&T data will open.
You cannot open multiple units of C&T data at one time. If C&T data is already
open, close it before receiving new C&T data.
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How to Send Data
Click [Send C&T Data] on the [Robot] pull-down menu.
The PC will start to send the C&T data to the robot.
When sending data, if any setting value included in the C&T data exceeds the entry
range, the upper/lower value of the range is transmitted instead. However, if a
sequencer program number or a point job data or additional function data number
assigned to the point data exceeds the entry range, “0” (meaning “not registered”) is
transmitted.

Only one unit of the C&T data can be saved in the robot at one time.
Accordingly, if you send C&T data from the PC to the robot, the data stored in
the robot will be overwritten (deleted.) To save data stored in the robot in a file,
close the data file to be transmitted briefly and click [Receive C&T Data.]
When transmitting C&T data while logged in, the PC will log out if the data does not
contain the account you are logged in under.
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COMMUNICATION SETTING
This section explains how to set communication parameters.
When sending or receiving data between the robot and the PC, select a COM Port for
the PC and match the communication parameters of the PC and the robot.
You cannot confirm or set the communication parameters for the robot via PC.

PC Communication Parameters
Click [COM Status] on the [Robot] pull-down menu.
Set up or confirm the communication settings for the PC.
Select the same [COM Port] number as that of
the connector on the PC connected to the
robot.
For the PC COM Port number, refer to the
instruction manual for your PC.
Set or confirm each parameter setting other
than the [COM Port] number to match that of
the robot.
This setting is valid only for communication with this application.

COM1
COM2
COM3
COM4

COM1

Robot

PC Operation
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Robot Communication Parameters
You cannot confirm or set the communication parameters for the robot via the PC.
To confirm or set the communication parameters for the robot, connect the teaching
pendant to the control box.
Start the robot in the Administration
mode.
Select [Administration Settings Mode]
from the Administration menu.

COM Setting
COM1 Communication Setting
COM2 Communication Setting
COM3 Communication Setting

Select [COM Setting] from the
Administration Settings Mode menu to
display the COM Setting screen. (See
right)

Select [COM1 Communication Setting]
to display the COM1 communication
settings. (See right)

COM1 Communication Setting
Baud Rate
9600
Character Length
8 bit
Stop Bit
1 bit
Parity
None

Confirm that each parameter setting
matches the PC communication
parameters.
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CONNECTION CONFIRMATION
SYSTEM INFORMATION
Click [Robot] on the menu bar and
then click [SystemInfo] on the pulldown menu.
Information about the robot
connected will be read out.
“Robot System Software Ver.
Number” is the system
version number built into the
robot, not the version number
of “LR C-Points.”
The “System Information” function
can be used to confirm the connection between the PC and the robot. Try this when
communication with the robot fails or when the robot cannot be operated. If the system
information cannot be read out, confirm the following. If the system information still
cannot be read out, try [Diagnosis Mode] (teaching pendant required) or contact your
dealer.
<Unable to Connect>

The power to the
Robot is ON.

The cable is
connected to proper
connectors.

Each communication
parameter is same.

Confirm that the “COM Port” number set in the
“COM Status” is the same as the COM Port
number of the PC connected to COM1 of the
robot.
Confirm that “COM1 Communication Settings”
for the robot are the same as the “COM
Status” for the PC (except for the “COM Port”
number.)

RS-232C cable
is used.
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SCREEN DISPLAY
This section explains how to change or restore the screen display.
Click [View] on the menu bar to display the following pull-down menu.
Tool Bar
Click this to display or to hide the tool bar.
Status Bar
Click this to display or to hide the status bar.
Refresh
Click this to redisplay the point data.
If any setting value included in the data exceeds the
entry range, the upper/lower value of the range is
displayed instead. However, if a sequencer program
number and point data or additional function data number assigned to the point data
exceeds the entry range, “0” (meaning “not registered”) is displayed.
Change View
Click this to select the point data display, horizontal or vertical.
Unit System
Click this to select the unit of length or coordinates from the following.
• mm (millimeter)
• in (inch)
Set View Language
Captions created in customizing mode can be displayed in a specified language.
If a caption is not set with specified language, it will be displayed in English.
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TEACHING DATA – PROGRAM
Open Program
A program is a part of the C&T data. To open a program, open C&T data first.
• New Program
To open a new program, click [Add Program] on the [Program] pull-down menu. The
following dialog box will appear. Select a new program number to be registered and
enter a name. You can use up to ten one-byte characters.
You cannot select a program number that
is already registered.

• Existing Program
Click the “▼” mark on the right of the program name display. (See below) The list of
programs included in the C&T data will be displayed. Select the desired program to be
opened.
Program Number

Program Name

You can also display the program list and select the desired program by clicking
[Program] on the menu bar and [Program Change] on the pull-down menu.
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Program Data
When a new program is opened, the following dialog box will be displayed. Click a tab
to enter or select a desired value. After entering the value, click [OK.]
This dialog box can also be viewed by clicking [Program Data] on the [Program] pulldown menu.
Tab
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Point Data
After opening a program using [Add Program], the point data alignments will be blank.
To register more than one point in a program, repeat [Add Point] as many times as
required.
Point Data Item

Point Data

• Enter/Change a Value
Click a cell and enter a value to be registered using the keyboard.

In the [Type] line, the “▼” mark will appear on the right of the cell when a cell is clicked.
Click this to display the list of point types. Select the point type to be registered.
• Edit
Select a cell or point to be edited and click [Edit] on the menu bar. The Edit menu will
appear.
This menu also appears by selecting a cell or point to be edited and right-clicking it.
To select a point, select all cells included in the point (except the point number line) or
click the point number.
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• Cut
The [Cut] operation is executed in points.
Select a cell and click [Cut] on the [Edit] pull-down menu. The point including the
selected cell will be deleted.
After the [Cut] operation, select a cell and click [Paste] on the [Edit] pull-down menu.
The clipped point will be inserted in front of the selected cell.
• Copy
Cell: Select a cell as copy source and click [Copy] on the [Edit] pull-down menu. Then select a cell
as copy destination and click [Paste] on the [Edit] pull-down menu. The copy source cell will be
overwritten onto the copy destination cell.

Point: Select a point as copy source and click [Copy] on the [Edit] pull-down menu.
Then
select a point as copy destination and click [Paste] on the [Edit] pulldown menu. The copied point will be inserted in front of the point where the
cursor is blinking.
Click [Paste After Last Point] to add the copied program to the end of the program.
• Paste/Paste After Last Point
By using these functions, you can paste not only the “clipped” or “copied” cell and point
but also data created by other applications, such as Lotus 1-2-3, Microsoft Excel®, and
Word®.
• Add Point
Click [Add Point] on the [Edit] pull-down menu. A point will be added to the end of the
point data alignments.
• Insert Point
Click [Insert Point] on the [Edit] pull-down menu. A point will be inserted in front of the
point data where the cursor is blinking.
• Delete Point
Click [Delete Point] on the [Edit] pull-down menu. The point data where the cursor is
blinking will be deleted.
The [Add Point], [Insert Point], and [Delete Point] operations also can be executed
by clicking the icons in the tool bar.
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• Block Copy
The [Block Copy] operation is executed in points.
Select a cell and click [Block Copy] on the [Edit] pull-down menu. The Block Copy
dialog box will appear.
Enter the range of copy source points (Start Point Number and End Point Number), copy
count (Copy Times) and offsets (Offset X, Y, Z, R), and then click [OK.] The copied
point block will be inserted just behind the original block.
• Mirror Copy (Right-Left/Front-Back)
The [Mirror Copy] operation is executed in points.
Select a cell and click [Mirror Copy] on the [Edit] pull-down menu. The Mirror Copy
dialog box will appear.
Enter the range of copy source points (Start Point Number and End Point Number) and
mirror position (Mirror Position X/Y), and then click [OK.] The copied point block will be
inserted just behind the original block.
• Offset Move
The [Offset Move] operation is executed in points.
Select a cell and click [Offset Move] on the [Edit] pull-down menu. The Offset Move
dialog box will appear.
Enter the range of offset move points (Start Point Number and End Point Number) and
offsets (Offset X, Y, Z, R), and then click [OK.]
The designated point coordinates will be converted.
• Block Rotation
The [Block Rotation] operation is executed in points.
Select a cell and click [Block Rotation] on the [Edit] pull-down menu. The Changing
Rotating Position dialog box will appear.
Enter the range of block rotation points (Start Point Number and End Point Number),
center of rotation and rotation angle, and then click [OK.]
The designated point coordinates will be converted.
• Multiple Line Speed
Line speed within the designated range of points can be converted in percentages. If
the converted value exceeds the setting range, the upper or lower value will be set
instead.
Click [Multiple Line Speed] on the [Edit] pull-down menu. The Multiple Line Speed
dialog box will appear. Enter the Start Point Number, End Point Number and Line
Speed Rate, and then click [OK.]
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• Reverse Point
Use this function to reverse the order of points within the designated range.
Click [Reverse Point] on the [Edit] pull-down menu. The Point Reverse dialog box will
appear. Enter the Start Point Number and End Point Number, and then click [OK.]
e. g. Start Point Number: 3, End Point Number: 5

P1, P2, P3, P4, P5, P6

P1, P2, P5, P4, P3, P6

• Transform into Relative
Use this function to convert the point coordinates in the currently selected program to
the relative coordinates.
• 2-Points Position Conversion
By designating two points of the conversion source and the corresponding two points of
the conversion destination, you can execute X, Y, and Z parallel and rotational
transform.
Click [2-Points Position Conversion] on the [Edit] pull-down menu. The 2-Points Position
Conversion dialog box will appear. Select the conversion range. Enter “Source
Position” and “Destination Position”, and then click [Calculate Amount.] The “Converting
Amount” will be calculated. Click [Converting Data] to convert the data coordinates
within the designated range according to the converting amounts.

Coordinate conversion data (Source Position, Destination Position, and Converting
Amount) used here is not included in the C&T data. Accordingly, this data can neither
be transmitted between the PC and the robot nor be saved in a file.
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TEACHING DATA CHANGE – POINT JOB DATA
Point job data is a part of the C&T data. Before creating and editing point job data, you
need to open the C&T data.
Click [Point Job] on the [Data] pull-down menu. The list of point job data will appear.
List

Contents of the currently selected point job data

(No. 1 in this example)
Copy
Copy and edit existing point job data to create similar data.
1. Select the point job data to be copied from the list and click [Copy.] The selection or
entry dialog box for the copy destination point job number will appear.
2. Select or enter the copy destination point job number.
Delete
1. Select the point job data to be deleted from the list and click [Delete.]
2. The Delete confirmation screen will appear. Confirm that the number is correct and
click [OK.]
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New (Add)
1. Click [Add] at the lower left of the list and select a point data number. The Point Job
Data Edit dialog box will appear. You cannot select numbers already registered.
You can change the size of the point job data edit dialog box. Click the
button
on the upper right corner of the dialog box to make it full-screen. Click and drag
the edge of the dialog box to change the size.
Command

Character/ Expression Entry
Command Line
Selection
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2. Select (Click) the desired command to enter or select the necessary parameters for
the selected command.
3. Enter or select (click) the necessary parameter(s.) You can enter the numeric
parameters using the keyboard.
4. Click [Register.] One command line will be registered and the highlight will shift to
the next line.
5. Repeat the above steps 3 – 5 as many times as required.
6. After entering all the commands, click [OK.]
When entering the point job name, you can use up to 40 one-byte characters.
The above steps 3 – 7 are also used when entering “Additional Function Data” and
“Sequencer Program” commands.
Edit
Use this function to correct existing point data.
1. Select the desired point job data number and click [Edit] at the bottom of the list. The point job
data edit dialog box will appear.
2. After one of the following operations, click [OK.]

Add a Command _ Select the last line of a command line (that contains no
command) on the left side of the screen. Then select (click) or
enter “command” and “necessary parameter(s)” in the order
described above. Click [Register.]
Insert a Command _ Select the desired command line on the left side of the
screen. Then select (click) or enter “command”, and “necessary
parameter(s)” in the order described above. Click [Register.]
One command line will be inserted in front of the selected
command line and the following command lines will shift
downward.
Delete a Command _ Select the desired command line on the left side of the
screen and Click [Delete.] The selected command line will be
deleted and the following commands will shift upward.
Change a Command _ After inserting a new command, delete the desired
command.
The above step 2 is also used when changing “Additional Function Data” and
“Sequencer Program” commands.
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TEACHING DATA CHANGE
– ADDITIONAL FUNCTION DATA
Additional function data is a part of the C&T data. Before creating and editing additional
function data, you need to open the C&T data.
Click [Additional] on the [Data] pull-down menu. The Additional Function Data list will
appear. Select the desired additional function data to be created or changed.

To create new additional function data, click [Add] and select a number from the unentered number list.
To change existing additional function data, select the desired data number to be
changed from the list (see below) and click [Edit.] The edit dialog box for the selected
additional function data will appear.

Contents of Currently Selected Data
(No. 1 in this example)

Existing Data
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Click [Add] to display
Un-entered Number List.

Edit
To edit existing additional function data, select the desired data number to be edited
from the list and click [Edit.] The edit dialog box for the selected additional function data
will appear.
• [PTP Condition], [CP Condition], [Tool Data], [Pallet Routine], [Work Adjustment]
Select or enter the desired item in the edit dialog box.
You can enter a name for [Pallet Routine] and [Work Adjustment.] Up to 10 one-byte
characters can be used.
• [Execute Condition]
You can enter or change a command in the same way as you would for point job
data. Enter or change a command and click [OK] in the edit dialog box.
Copy
Select the desired additional function data number to be copied from the existing data
list and click [Copy.]
The selection or entry screen for the copy destination additional function data number will appear.
Select or enter the copy destination data number.

Delete
Select the desired additional function data number to be deleted from the existing data
list and click [Delete.]
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TEACHING DATA CHANGE
– SEQUENCER PROGRAM
Sequencer program data is a part of the C&T data. Before creating and editing
sequencer program data, you need to open the C&T data.
Click [Sequencer] on the [Data] pull-down menu. The list of sequencer program data will
appear.

New (Add)
Click [Add] in the lower left corner of the box and select a sequencer program data
number. The edit dialog box for the selected sequencer program data will appear.
Edit
To edit existing sequencer program data, select the desired data number to be edited
from the list and click [Edit.] The edit dialog box for the selected sequencer program
data will appear.
You can enter or change sequencer program data in the same way as you would for
point job data. You can enter a name for sequencer program data. Up to 10 one-byte
characters can be used.
Copy
Select the desired sequencer program data number to be copied from the list and click
[Copy.]
The selection or entry screen for the copy destination sequencer program data number will appear.
Select or enter the copy destination data number.

Delete
Select the desired sequencer program data number to be deleted from the list and click
[Delete.]
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TEACHING DATA CHANGE
– RUN MODE PARAMETER
Run mode parameter is a part of the C&T data. Before setting the run mode parameter,
you need to open C&T data.
Run mode parameter consists of the following items. Select the desired item to be
changed.
IO Settings
Program Number Changing Way
Program Number Reading Code
IO-SYS Function Assignment
IO-S Function Setting
Job and Sequencer on Run Mode
Job on Power ON
Job on Emergency Stop
Job on Playback Error
Job on System Error
Job on Start of Run Mode
Job on Start of Cycle
Job on End of Cycle
Job on Stopping
Job on Starting
Job while Stopping (Cycle Top)
Job while Stopping (In Cycle)
Sequencer Program on Run Mode
Point Reset Settings
Reset at Power ON
Reset at Emergency
Reset at Going Home
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ROBOT OPERATION VIA PC
To establish communication between the PC and the robot or to operate the robot via
the PC, click [Robot] on the menu bar. The following pull-down menu will appear.

To operate the robot via the PC in the
Be sure to turn off the
SCARA series, you need to connect
power to the PC and the
the grip switch to the teaching
robot before inserting
pendant connector on the control box.
or removing the cable.
In the Cartesian series, if a teaching
pendant with an emergency stop
switch and an enable switch is used, you need to also connect the grip switch to
the teaching pendant connector. (See page 3)
The robot can execute [JOG (JOG Teaching)], [GO Move], and [GO plus Move]
operations only in the teaching mode. Enter the teaching mode using the select
key switch on the control box.
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If a teaching pendant without an enable switch is used with the Cartesian series, it
is not necessary to press the enable switch on the grip switch when instructed to
do so in the manual.

Mechanical Initialization (for the Cartesian series only)
Execute mechanical initialization of the robot.
Select “Meca Initialize” from “Robot” pull-down menu in the menu bar (while pressing the
enable switch.) The robot executes mechanical initialization. The robot will not move
unless mechanical initialization is executed after the robot power is turned ON.
Motor Power ON (for the SCARA series only)
Use this function to turn the motor power to the robot ON.
Click [Motor Power ON] on the [Robot] pull-down menu. The motor power to the robot
will be turned ON. The robot cannot start unless the motor power is ON.
GO Move
Click [GO Move] on the [Robot] pull-down menu while pressing the enable switch.
Each robot Axis will shift to the point coordinates where the cursor blinks.
GO plus Move
Click [GO Plus Move] on the [Robot] pull-down menu while pressing the enable
switch.
Each robot Axis will shift to the point coordinates where the cursor blinks, and then the
cursor will shift to the next point.
Point Playback/Test Running
Click [Point Playback] or [Test Running] on the [Robot] pull-down menu while pressing
the enable switch.
These two operations will be executed according to the C&T data stored in the robot
RAM. For teaching data created using the LR C-Points and stored in the PC, first
execute [Send C&T Data] in order to execute [Point Playback] or [Test Running.]
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JOG (JOG Teaching)
Use this function to register point coordinates in JOG mode.
Place the cursor on the point to be registered and then click [JOG] on the [Robot] pulldown menu. The JOG dialog box will appear. (See next page)
If you select a point other than normal job points (e.g. work home), click the JOG icon
in the point setting dialog box.
• Mode, Servo State (for the SCARA series only)
You can select the position entry mode for the robot. If you select [Direct], set [Servo
State] to [Free] (Servo OFF.) Any Axis set to [Hold] cannot shift in the Direct mode.
You can enter the coordinate values in the “Coordinates” (X, Y, Z, R) sections using the
numeric keys.
If you start the robot in the “Servo Free” (Servo OFF) state, any Axis set to [Free]
will not shift. Before starting the robot, set [Servo State] to [Hold] (Servo ON) or
change [Mode] to [JOG.] When turning to the JOG mode, each Axis
automatically will be Servo ON state.
• Coordinate System (for the SCARA series only)
You can select the coordinate system for the robot. If [J1-J2] is selected, the JOG key
function will change from [X, Y, Z, R] to [J1, J2, J3, J4.]
• Point Number (to be registered)
The number of the point where the cursor blinks when opening the dialog box will be
displayed here. You can change the number. This item will not appear if you do not
select a normal job point.
• Point Job
Click the “▼” on the right side of [Point Job] to display the list of the point job data
registered in the C&T data. The selected point job data will be executed if you click
[Execute] while pressing the enable switch.
Note that the robot executes the point job data stored in the robot. If the point job data
to be executed differs from that stored in the robot, you need to send the data to the
robot (execute [Send C&T Data]) first.
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• JOG Key
Click these buttons while
pressing the enable switch on the
grip switch. The corresponding
robot Axis will shift. Release the
button to stop.
The Axis display varies according
to the selected coordinate
system.
• Speed (for the SCARA series
only)
You can select the JOG shifting
speed between [Low], [Middle],
and [High.]
• Coordinates
The point coordinates where the
cursor blinks when opening the
dialog box are displayed here.
Click [Robot Pos’n] to display the
current robot position coordinates
and [Point Pos’n] to display the
designated point coordinates.
Click [GO] while pressing the
enable switch to shift each robot
Axis to the currently displayed
position coordinates.
• Arm Shape
Select [Righty] or [Lefty] and then click [GO] while pressing the enable switch. The robot
will shift to the position coordinates that the selected Arm is pointing to.
• Register
Click this button to fix the coordinates and to close the dialog box.
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• GO
Click this button while pressing the enable switch. Each robot Axis will shift to the
currently displayed position coordinates.
• Mechanical Initialization (for the Cartesian series only)
Execute mechanical initialization of the robot. The robot will not move unless
mechanical initialization is executed after the robot power is turned ON.
• Motor Power ON (for the SCARA series only)
Click this button to turn the motor power to the robot ON. The robot cannot start unless
the motor power is ON.
• Close
Click this button to abandon the coordinates and to close the JOG dialog box.
If the JOG dialog box is open, you can shift the robot Axes using the PC keyboard.

X-Y

Axis
-X
+X
-Y
+Y
-Z
+Z
-R
+R
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Axis
-J1
+J1
-J2
+J2
-J3
+J3
-J4
+J4

Key
D
F
E
R
C
V
T
Y

Cartesian & SCARA Robots

If you cannot operate the robot via PC, open “System Information” to confirm the
connection between the PC and the robot. If the System Information dialog box
opens normally, confirm the following. If you still cannot execute the JOG
operation even after having checked all items, try [Diagnosis Mode] (teaching
pendant required) or contact your dealer.
<Unable to operate from PC>
The grip switch
is connected.

•

If a teaching pendant without an enable switch
and an emergency stop switch is used with the
Cartesian series, a grip switch is not necessary.

•

If a teaching pendant without an enable switch
is used with the Cartesian series, it is not
necessary to press the enable switch.

•

For the Cartesian series only

•

For the SCARA series only

The enable switch
is pressed.

Mechanical initialization
is executed after the
robot power is turned
ON.

The motor power to
the robot is ON.

The robot is in the
teaching mode.

•
• For the SCARA series only
Set [Mode] to [JOG] in the JOG dialog box. All
Axes will automatically be in the Servo ON state.

Each robot Axis is in
the Servo ON state.
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External I/O
Click [External I/O] on the [Robot] pull-down menu. The current external I/O status of
the robot will be displayed.

Red lamps indicate the signals currently ON.
Click the buttons on the dialog box to toggle the external signals ON or OFF.
When Using I/O-U (Optional for the SCARA series only)

I/O-U (optional) is an extension of I/O-H. However, the above I/O-H ON/OFF display is
not the I/O-U status because it only displays information on the internal board in the
control box.
With I/O-U

I/O-H

Robot

I/O-U

Tool
Controller

Control
Box

Tool

Without I/O-U
I/O-H

Robot
Control Box
Internal Board
Tool
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EXTERNAL START CHANNEL
External Start
You can select one of the following two channels for the robot to receive the external
start signal through. You cannot select both at one time.
• COM1
• I/O-1
Click [External Start] on the [Robot] pull-down menu.
The External Start dialog box will appear.
Select the desired start channel and click [OK.]
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SYSTEM ERROR INFORMATION
RUN ERROR INFORMATION
Click [System Error Information] or [Run Error Information] on the [Robot] pull-down
menu. Any error information regarding the connected robot will be read out and
displayed.
If an error occurred while the robot was not connected to the PC, turn off the power to
the robot and the PC briefly before connecting the two. Then start up them to read out
the error information.
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PRINT
You can print out the C&T data.
Click [Print] on the [File] pull-down menu.
The Print setting dialog box will appear.
Select the desired item to be printed and click
[OK.]
Set the print range to [All] to select all the C&T
data (the unit described on page 10.)
The Print confirmation dialog box will appear.
Click [OK] to start printing.

Click [Print Preview] to see the print image. If you want to print out a particular program
or point job, locate the page numbers using the Print Preview and then set the page
count in the Print dialog box.
Click [Print Setup] to change the print setting.
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CUSTOMIZING DATA – TMC SETTING
TMC setting (Teaching Mode Customizing Data) is customizing data which is not
restricted by account. Settings can be changed without logging in.
Select the item you want to set from the “Set T.M.C” pull-down menu of the menu bar.
The setting dialog for the selected item will be displayed.
Select the item you want to set from the dialog box and click [OK.]
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CUSTOMIZING DATA - ACCOUNT
To define or create customizing data (except for TMC setting), it is necessary to login by
setting an account. Up to 50 accounts can be set. Once you login, you remain loggedin under the same account until you logout or terminate LR-CPoints.
It is not possible to log in simultaneously using multiple accounts.
Customizing data (except for TMC setting) is protected by account (account restriction.)
Access restriction varies depending on the type of “Protect Mode” (See the table below.)
Protect Mode can be set for each set of data.
<Access restriction to other accounts>
Protect
No
Public Protected
Mode
Restriction
Use data
View
contents
Change
contents

Private

○

○

○

×

○

○

×

×

○

×

×

×

■ Login
To login using the existing account,
select “Login” from the pull-down menu
under “Customize” in the menu bar.
The dialog box shown to the right will
be displayed.
Enter your Login name and Security
Code and click [OK.]
To login using a new account, see
“Make Account.”
This robot has a special account which does not require entry of a Login name
(user) and Security Code. This account is useful for creation or setting customizing
data which does not require protection by an account.
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Logout
To logout, select “Logout” of the pull-down menu from “Account” in the menu bar.

Make Account
To make a new account, select
“Make Account” from the pull-down
menu under “Customize” in the menu
bar. The dialog box shown to the
right will be displayed.
Enter a Login Name and Security
Code twice and click [OK.]
You can now login using the new
account.

Delete Account
To delete an account, select “Delete Account” from the pull-down menu under “Account”
in the menu bar. If an account is deleted, all customizing data included in the account
will be deleted too.

Change Security Code
Change the security code used to login.
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Inhibit Copying
You can choose Valid or Invalid. If “Valid” is set under “inhibit Copying”, when C&T data
is sent from PC to the robot it will not be sent unless the robot is using the same
account.

Inhibit Copying to the Other Robot
You can choose Valid or Invalid. If “Inhibit Copying to the Other Robot” is set to “Valid”
when C&T data is sent it will not send if the unit identification number is different.

Transfer
Transfer all account data being logged in to another account.
Select “Transfer” from the pull-down menu under “Account” in the menu bar and enter
an account to transfer to. If data is transferred, all the account data in the original
location will disappear.
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CUSTOMIZING DATA
Customizing data is protected by account. It is not possible to edit customizing
data through another account. To create or set customizing data, select an
account to login under.
Select the customizing data you want to create or set from the pull-down menu under
“Customize” in the menu bar. A list of customizing data will be displayed. Click [Add] to
create new customizing data. Click [Edit] to modify the existing data. The setting dialog
box for the selected item will be displayed.
To copy or delete data, specify the data and select [Copy] or [Delete.]
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ROBOT SYSTEM VERSION UPGRADE
Robot system software is built-in system software that controls the robot. Follow the
steps below to upgrade the robot system software.
“Robot System Software” is the file with the extension is “.jsy”, included in Operation
Manual CD-ROM.
1. Turn the power to the robot OFF. Remove the switch cover from the front of the
control box (for the SCARA series) or the left side of the robot body (for the
Cartesian series) to toggle the special mode switch to ON.
Inside the Cover
Special Mode
<SCARA Series>
Control Box (Front)

< Cartesian Series>
Left Side of the Body

Special Mode
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2. Turn the power to the robot ON and insert the Operation Manual CD-ROM into the
PC CD drive.
3. Start up “LR C-Points” and click [Send Robot System Software] on the [Robot] pulldown menu.
The following dialog box will appear.

4. Click [Open] and specify the CD drive into which the Operation Manual CD-ROM
has been inserted.
5. Select the “Robot System Software” file with the extension “.jsy” and click [Open.]
The file name will be displayed in the dialog box title bar.
6. Click [Send] to start sending the robot system software.
7. After the transmission, turn the power to the robot OFF. Toggle the special mode
switch to OFF and reattach the switch cover.

PC Operation

56

Cartesian & SCARA Robots

CAD DRAWING FILE CONVERSION (Dxf2Robot)
The “Dxf2Robot” software is designed to convert a CAD drawing file (extension “DXF”
file) to a file that can be read using LR C-Points.
The converted (extension “JCS”) file can be read using the [Import] function (in the [File]
menu) of LR C-Points.
Preparation
The “Dxf2Robot” software cannot be installed using the same installation process as for
LR C-Points. Copy the “D2RJ.EXE file from the ”LR C-Points” CD-ROM to a local disk.
(Copy Destination Example) C:\Program Files\Henkel\LRPSJ
Operation
1. Double-click the D2RJ.EXE icon. The following dialog box will appear.

2. Click [Select (Add)] to select a DXF file to be converted and then click [Open.] The
selected file name will be displayed in the “List of source files (DXF Files)” section.
If you want to convert multiple DXF files, repeat this procedure to display the file
names in the “List of source files (DXF Files)” section.
To abandon the conversion of a file, select (highlight) the file name to be canceled
and click [Cancel.]
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3. Click [Browse] to designate a folder to save the converted file(s) into.
4. Click [Convert All.] All the files displayed in the “List of source files (DXF Files)”
section will be converted to JCS files and saved in the location selected under
“Saving Folder” section.
Click [Convert] to convert only the selected (highlighted) file in the “List of source
files (DXF Files)” section and save it in the location selected under “Saving Folder”
section.
5. After the transmission is complete, click [Exit] to exit “Dxf2Robot.”

Notice
• Up to 500 DXF files can be converted at one time.
• The DXF file to be converted should contain only one layer.
• The DXF file to be converted should not contain either the dimension line, frame,
proxy object (zombie), or 3D solid.
• The DXF file to be converted should contain less than 10,000 functions.
Functions to be converted are as follows:
ARC (arc), CIRCLE (circle), LINE (line), POINT (point), POLYLINE (continuous
line),VERTEX (vertex), LWPOLYLINE (continuous line), SEQEND (end of
continuous line), ENDSEC (end of section)
•
•
•

An arc will be converted counterclockwise except when an arc and a line are
combined.
A circle will be converted as two arcs. In this case, the start point of the arc is
always right side (three o’clock position) of circle.
The unit of length cannot be converted. Values in the DXF file will be converted
directly. You can select either “mm” or “inch” when reading the file with the “LR CPoints.”

e.g. Combination of
Arc and Line
Start Point

Counterclockwise
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CONVERTING DATA
FROM 98xxx INTO 98xxxA Series
If you are using 98xxx teaching data as 98xxxA C&T data, it is necessary to convert the
data. To convert data, follow these 3 steps.
1)
2)
3)

Using “LR-Points”, load data onto the PC from the 98xxx.
Using “LR C-Points”*, open the data sent in 1).
Using “LR C-Points”*, send the data from your PC to the 98xxxA.

Teaching Data

Connect

Connect

98xxx

PC(LR-Points)

PC(LR C-Points)

98xxxA

* As well as “LR C-Points”, “LR C-Points Limited Edition (included in Operation Manual
CD-ROM)” can also be used to convert data.
You can connect one PC to both the 98xxx series and the 98xxxA series robots
together. It is also possible to connect the PC only to the 98xxx series robot to
receive teaching data, disconnect the 98xxx robot and then connect the 98xxxA
series robot to send the teaching data.
(To convert data using one PC, both “LR-Points” and “LR C-Points” have to be
installed on the PC.)
Be sure to turn the power to
the robot and PC OFF before
connecting or disconnecting
cables.
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Follow the steps below to convert teaching data.
(For a PC with “LR-Points” and “LR C-Points” installed, connected to the 98xxx series
and 98xxxA series robots.)
1. Turn the power to the robot and PC ON. In Run mode, the robot has to be in standby to run. In other modes, it has to be in a base state.
2. Start up “LR-Points” on the PC and set the port status to a COM port connected to
the 98xxx series robot.
[Robot]
[COM Status]
PC
3. Transfer teaching data from the 98xxx series robot.
[Robot]
[Receive Data]
PC
4. When data transfer is completed, the data is opened in “LR-Points.” Name the
received data and save it.
[File]
[Save As]
PC
5. Exit “LR-Points” and start up “LR C-Points.”
6. Set the port status to a COM port connected to the 98xxxA series robot.
[Robot]
[COM Status]
PC
7. Open the data file from the 98xxx series robot.
[File]
[Open]
PC
8. Send the data to the 98xxxA series robot. Note that when data is sent from the PC
to the robot, any data stored in the robot is deleted.
[Robot]
[Send Data]
PC

For operation environment of “LR-Points”, refer to the operation manual for LRPoints.
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COMMUNICATION CABLE (RS-232C) WIRING
Use a 9-pin D-SUB connector for the robot.
The robot is cross-cabled as follows. Use a straight cable when connecting the host
(e.g. PC) and the robot.

Host Side: 9-Pin D-SUB
COM1 (RS-232C Port)
Host (PC)

Robot

PIN
No.
3
2

Terminal

Function

PIN
No.
3
2

RXD
TXD

Receive Data
Transmit Data
Request to
8
RTS
Send
7
CTS
Clear to Send
5
GND
Ground
Connector: 9-Pin D-SUB

Terminal
TXD
RXD

8
7
5

CTS

Function
Transmit Data
Receive Data
Clear to Send

RTS
Request to Send
GND
Ground
Connector: 9-Pin D-SUB

Host Side: 25-Pin D-SUB
COM1 (RS-232C Port)
Robot

PIN
No.
3
2

Host (PC)

Terminal

Function

PIN
No.
2
3

RXD
TXD

Receive Data
Transmit Data
Request to
8
RTS
Send
7
CTS
Clear to Send
5
GND
Ground
Connector: 9-Pin D-SUB

5
4
7

Terminal
TXD
RXD
CTS

Function
Transmit Data
Receive Data
Clear to Send

RTS
Request to Send
GND
Ground
Connector: 25-Pin D-SUB

For the host (PC) side, use a cable compatible with your PC.
The 9-pin D-SUB is normally connected to the serial port marked with [I O I O] on the
rear side of the PC.
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Warranty
Henkel Corporation warrants, to the original Buyer for a period of one (1) year from date
of delivery, that the Loctite® Equipment or System sold by it is free from defects in
material and workmanship. Henkel will, at its option, replace or repair said defective
parts. This warranty is subject to the following exceptions and limitations.
1. Purchaser Responsibilities – The Purchaser shall be responsible for:
-Maintenance of the equipment as outlined in the Equipment Manual for the product.
- Inventory of recommended maintenance parts established by Henkel;
-Notification to Henkel within 6-8 hours of downtime.
-Any cost of travel or transportation connected with warranty repair.
-All cost associated with investigating or correcting any failure caused by the
purchaser’s misuse, neglect or unauthorized alteration or repair.
-All costs attributed to accident or other factors beyond Henkel’s control.
2. A thirty (30) day warranty will be extended on any items subject to normal wear, such
as:
-Tubing
-Pump Seals
-Wear Surfaces of Wiping Rollers
-O-Rings
-Hoses
Purchased items used in Loctite® dispensing equipment are covered under warranties
of their respective manufacturers and are excluded from coverage under this warranty.
Typical purchased items are:
-Electrical Relays
-Refrigeration Units
-Solenoids
-Timers
-Fluid Power Cylinders
-Electrical Motors
3. No warranty is extended to perishable items, such as:
-Fuses
-Dispensing Needles -Dispensing Nozzles
-Light Bulbs
-Lamps
-Product Barrels
Henkel reserves the right to make changes in design and/or improvements to its equipment without
obligation to include these changes in any equipment previously manufactured.
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Henkel’s warranty herein is in lieu of and excludes all other warranties of Henkel and its affiliated
and related companies (hereinafter the “seller companies”), express, implied, statutory, or
otherwise created under applicable law including, but not limited to, any warranty or
merchantability and/or fitness for a particular purpose of use. In no event shall the seller and/or
the seller companies be liable for any direct, indirect, special, incidental or consequential
damages, including, but not limited to, loss of profits. In addition, this warranty shall not apply to
any products, which have been subjected to abuse, misuse, improper installation, improper
maintenance or operation, electrical failure or abnormal conditions; and to products, which have
been tampered with, altered, modified, repaired or reworked by anyone not approved by seller.
Buyer’s sole and exclusive remedy under this warranty shall be limited to, at seller’s discretion,
the replacement or repair of any defective product or part thereof, or a refund of the purchase
price paid by for the product in exchange for buyer’s return of the product to seller, free and clear
of any and all liens and encumbrances of any nature.

The specifications of the robot or the contents of this manual may be
modified without prior notice to improve its quality.
No part of this manual may be reproduced in any form, including
photocopying, reprinting, or translation to another language, without the
prior written consent of LOCTITE®.
©2005, JSMC., Ltd., All rights reserved.

P/N 989524 PC Operations Manual, 11/2005
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